В начало

Выборка по справочнику «Номенклатура»

 

            Имеется справочник «Номенклатура», содержащий список товаров и услуг распределенных по группам (рис.1). Нужно программно сделать выборку элементов справочника «Номенклатура».

 

Рис. 1. Справочник «Номенклатура»

Рис. 1. Справочник «Номенклатура»

 

Простейший листинг процедуры, выполняющей выборку и вывод элементов справочника «Номенклатура» показан ниже.

Листинг 1

&НаСервере

Процедура ВыводСодержимогоСправочника ()

      Выборка = Справочникиоменклатура.Выбрать();

      Пока Выборкаледующий () Цикл

            Если ВыборкатоГруппа = Истина

//Вывод названия группы в ВЕРХНЕМ регистре

                  Тогда Сообщить (Выборкаод + "    " + ВРег (Выборка.Наименование))

//Вывод ЭЛЕМЕНТОВ справочника с небольшим сдвигом влево

                  Иначе Сообщить (" " + Выборкаод + "     " + Выборка.Наименование);

            КонецЕсли;

      КонецЦикла;

КонецПроцедуры

 

&НаКлиенте

Процедура Отладка (Команда)

      ВыводСодержимогоСправочника ();

КонецПроцедуры

 

 

           

            Результат выполнения процедуры выборки показан на рис.2. Судя по всему, перебор в выборке осуществляется по наименованию (алфавиту).

Рис. 2. Результат выполнения процедуры

Рис. 2. Результат выполнения процедуры

 

ПРИМЕЧАНИЕ: процедура тестировалась на 1С: Предприятие 8.2.