В начало

Множественный выбор в справочнике Номенклатура

 

Есть справочник Номенклатура и документ Расходная. Требуется организовать множественный выбор номенклатуры с помощью формы выбора справочника Номенклатура.

Для формы выбора справочника Номенклатура необходимо установить свойства РежимВыбора и Множественный выбор, т.е. поставить соответствующие галочки.

 

Рис. Свойства формы выбора справочника Номенклатура

Рис. Свойства формы выбора справочника Номенклатура

 

            Далее для элемента Номенклатура формы документа Расходная необходимо найти событие ОбработкаВыбора и для него заполнить процедуру.

 

Рис. Элемент Номенклатура формы документа Расходная

 

Листинг. Процедура обработки выбора для элемента Номенклатура

&НаКлиенте

Процедура ТоварыНоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)       

      Если ТипЗнч(ВыбранноеЗначение) = Тип("Массив") Тогда

            Для каждого З Из ВыбранноеЗначение Цикл

                  Стр=Элементыовары.ТекущиеДанные;

                  Строменклатура=З;

                  Элементыовары.ДобавитьСтроку();

            КонецЦикла;

      КонецЕсли;

КонецПроцедуры

 

            После этого запускаемся в режиме 1С:Предприятие и проверяем как переносятся выбранные значения номенклатуры из формы формы выбора справочника Номенклатура в табличную часть документа Расходная.

Рис. Форма выбора справочника Номенклатура

 

Рис. Табличная часть документа Расходная