В начало

Выборка по регистру сведений

 

            Есть регистр сведений «Курсы», содержащий записи курсов валют по периодам. Требуется выбрать курсы валют за определенный интервал.

Рис.1. Регистр сведений «Курсы»

 

Листинг 1. Код процедур

&НаСервере

Процедура ЧтениеРегистра (ДатаНачала, ДатаКонца)

      Выборка = РегистрыСведенийурсы.Выбрать(ДатаНачала, ДатаКонца);

            Пока Выборкаледующий () Цикл

            Сообщить (Выборкаурс);

            КонецЦикла;

КонецПроцедуры

 

&НаКлиенте

Процедура Кнопка (Команда)

      ДатаНачала = '20140413';

      ДатаКонца = '20140415';

      ЧтениеРегистра (ДатаНачала, ДатаКонца);

КонецПроцедуры

 

Рис.2. Выборка значений курсов валют с 2014-04-13 по 2014-04-15

 

ПРИМЕЧАНИЕ: код проверен на 1Средприятие 8.2.