В начало

Добавить запись в РС «Курсы»

 

            Есть периодический регистр сведений (РС) «Курсы», содержащий записи курсов валют по дням. Требуется проверить запись регистра и если она пуста, т.е. ее нет, то добавить новую, в данном конкретном случае ­– курс валюты в заданный период.

 

Листинг 1. Процедуры

&НаСервере

Процедура ДобавлениеЗаписиВРегистр (Дата, Курс)

    МЗ = РегистрыСведенийурсы.СоздатьМенеджерЗаписи ();

            МЗериод = Дата;

            МЗрочитать ();

            Если Не МЗыбран () Тогда //Если записи НЕТ, то добавляем

                        МЗериод = Дата;

                        МЗурс = Курс;

                        МЗаписать ();

            КонецЕсли;     

КонецПроцедуры

&НаКлиенте

Процедура Кнопка (Команда)

            Дата = '20140418';

            Курс = "35.88";

            ДобавлениеЗаписиВРегистр (Дата, Курс);

КонецПроцедуры

 

ПРИМЕЧАНИЕ: код работает в  1С: Предприятие 8.2.