В начало

Чтение записей регистра наоборот

 

            Есть регистр сведений «Курсы», в который записаны курсы валют по периодам. Необходимо прочитать записи регистра сведений в обратном порядке, т.е. начиная с последней записи.

Листинг 1

&НаСервере

Процедура ЧтениеНабораЗаписейРегистраНаоборот ()

            Набор = РегистрыСведенийурсы.СоздатьНаборЗаписей ();

            Наборрочитать ();

           

            К = Набороличество (); //Число записей

            Для Н = 1 По К Цикл

                        ТекСтрока=Набор[К-Н]; //Чтобы записи читались в ОБРАТНОМ порядке

                        Сообщить ("" + ТекСтрокаериод + " " + ТекСтрока.Курс);

                        // Если НЕ поставить в начале строки "", то строки будут сложены и

// выведены

            КонецЦикла;

КонецПроцедуры

&НаКлиенте

Процедура Кнопка (Команда)

            ЧтениеНабораЗаписейРегистраНаоборот ();

КонецПроцедуры

 

Рис. 1. Чтение записей регистра в обратном порядке

Рис. 1. Чтение записей регистра в обратном порядке

 

ПРИМЕЧАНИЕ: код работает в 1С: Предприятие 8.2.