В начало

Чтение набора записей регистра

 

            Чтобы прочитать набор записей регистра сведений поможет нижеприведенный код, в нем мы последовательно и методично обходим все записи набора в цикле.

Листинг 1. Процедуры в модуле

&НаСервере

Процедура ЧтениеНабораЗаписейРегистра ()

            Набор = РегистрыСведенийурсы.СоздатьНаборЗаписей ();

            Наборрочитать();

           

            Для Каждого ТекСтрока Из Набор Цикл

                        Сообщить("" + ТекСтрокаериод + " " + ТекСтрока.Курс);

                        //Если НЕ поставить в начале строки "", то «Период» будет СЛОЖЕН

// с «Курсом» и уже потом выведен!

            КонецЦикла;

КонецПроцедуры

&НаКлиенте

Процедура Кнопка (Команда)

            ЧтениеНабораЗаписейРегистра ();

КонецПроцедуры

 

Рис. 1. Результат чтения набора записей регистра

Рис. 1. Результат чтения набора записей регистра

 

ПРИМЕЧАНИЕ: код работает в 1С: Предприятие 8.2.