В начало

«Закупочные цены» с запросом

 

            Есть некий регистр сведений «ЗакупочныеЦены», нужно создать отчетик по нему, используя запрос.

            Запускаем конфигуратор, переходим в нужный раздел и создаем новый отчет «ЗакупочныеЦены». Выводить в отчет будем измерения регистра сведений и естественно ресурс.

Рис. 1. Регистр сведений, заполненный на скорую руку

Рис. 1. Регистр сведений, заполненный на скорую руку

 

            После создания нового отчета, нужно перейти в раздел «Макеты» и создать макет нашего представления о будущем отчете. Макету необходимо выбрать тип «Табличный документ». Макет будет представлять из себя шапку и таблицу из 3 колонок. Для задания имени областей нужно выделить строки и выбрать в главном меню «Таблица – Имена – Назначить имя…». А для того чтобы задать параметры таблицы нужно в свойствах ячеек выбрать «Макет – Заполнение – Параметр».

Рис. 2. Макет отчета

Рис. 2. Макет отчета

 

            Далее переходим к созданию формы отчета, она создается в разделе «Формы». Для формы отчета создаем реквизит «ТабДок» с типом табличный документ и кнопку для вывода отчета и «ДатаОтчета» с типом дата. Перетаскиваем их в раздел «Форма», который находится в левой части, после этого кнопка и пустой табличный документ сразу отобразятся внизу. Если выбрать для кнопки раздел свойств «Основные ­– Действие», то будет создан шаблон процедуры и автоматический переход в модуль формы, в котором собственно надо немного покодить.

 

Рис. 3. Форма отчета

Рис. 3. Форма отчета

 

            Затем заполняем процедуры. Запрос легко создать через контекстное меню, выбрав «Конструктор запроса…» и следуя далее указаниям мастера. Форматную строку, кстати, также, только нужно выбрать «Конструктор форматной строки…».

Листинг 1. Процедуры в модуле формы

&НаКлиенте

Процедура СформироватьОтчет(Команда)

      СформироватьОтчетНаСервере(ТабДок, ДатаОтчета);

КонецПроцедуры

 

&НаСервереБезКонтекста

Процедура СформироватьОтчетНаСервере(ТабДок, ДатаОтчета)

      //Синтаксис языка довольно чудесатый,

      //Единообразия вообще нет

      //Макет и области получаем по строковому названию,

      //параметры в макете задаем через точку,

      //а выводим область по имени

      Макет = ОтчетыакупочныеЦены.ПолучитьМакет("Макет");

      Область_Ш = МакетолучитьОбласть("Шапка");

      Область_С = МакетолучитьОбласть("Строка");

      Область_Ш.ПараметрыатаОтчета = Формат(ДатаОтчета, "ДФ=dd.MM.yyyy");

      ТабДокчистить();     

      ТабДокывести(Область_Ш);  

     

      Запрос = Новый Запрос;

      Запросекст =

      "ВЫБРАТЬ

      |     Контрагент,

      |     Номенклатура,

      |     Цена

      |ИЗ

      |     РегистрСведенийакупочныеЦены.СрезПоследних(&ДатаОтчета, )";

      ЗапросстановитьПараметр("ДатаОтчета", ДатаОтчета);

      Результат = Запросыполнить(); //Получаем результат

      Выборка = Результатыбрать();//Создаем выборку

      Пока Выборкаледующий() Цикл

            Область_С.Параметрыонтрагент = Выборка.Контрагент;

            Область_С.Параметрыоменклатура = Выборка.Номенклатура;

            Область_С.Параметрыена = Выборка.Цена;

            ТабДокывести(Область_С);

      КонецЦикла;

КонецПроцедуры

            После этого запускаемся в режиме «1Средприятие», выбираем наш отчет и формируем его. Ниже показан внешний вид отчета.

Рис. 4. Сформированный отчет

Рис. 4. Сформированный отчет

 

ПРИМЕЧАНИЕ: отчет создан на версии 8.3.