В начало

«Список сотрудников» с макетом

            Есть справочник «Сотрудники». Нужно сформировать отчет «Список сотрудников» на основании данных этого справочника, используя макет.

Рис. 1. Справочник «Сотрудники»

Рис. 1. Справочник «Сотрудники»

 

            Запускаем 1С в режиме конфигуратора, в дереве объектов переходим в раздел «Отчеты» и создаем новый отчет, которому даем имя «СписокСотрудников».

            Потом переходим за закладку «Макеты» и создаем макет будущего отчета. В качестве типа выбираем в конструкторе «Табличный документ». В макете создаем 2 области: «Шапка» и «Строка». Для задания имени области необходимо выделить строки, после чего в главном меню конфигуратора выбрать раздел «Таблица – Имена – Назначить имя…». Для того, чтобы данные выводились в строку таблицы необходимо задать имена параметров «ФИО» и «ДатаРождения», выделить их и потом указать свойства «Макет – Параметр».

Рис. 2. Макет отчета «СписокСотрудников»

Рис. 2. Макет отчета «СписокСотрудников»

 

Далее переходим на закладку «Формы» и создаем форму отчета. На форме добавляем новый реквизит «ТабДок». Задаем его тип «Табличный документ». Можно убрать у него авто-заголовок, выбрав на закладке свойств «Основные – Положение заголовка – Нет». Затем  создаем кнопку в разделе «Команды» с названием «Сформировать», чтобы было чем формировать отчет.

Листинг 1. Процедуры в модуле формы

&НаКлиенте

Процедура Сформировать(Команда)

            СформироватьНаСервере(ТабДок);

КонецПроцедуры

 

&НаСервереБезКонтекста

Процедура СформироватьНаСервере(ТабДок)

            ТабДокчистить();

            Макет = ОтчетыписокСотрудников.ПолучитьМакет("Макет");

            Область_Шапка = МакетолучитьОбласть("Шапка");

            ТабДокывести(Область_Шапка);

           

            Выборка = Справочникиотрудники.ВыбратьИерархически();

            Пока Выборкаледующий() Цикл

                        Область_Строка = МакетолучитьОбласть("Строка");

                        Область_Строкаараметры.ФИО = Выборка.Наименование;

                        Область_Строкаараметры.ДатаРождения = Выборка.ДатаРождения;

                        ТабДокывести(Область_Строка);

            КонецЦикла;   

КонецПроцедуры

 

Рис. 2. Результат формирования отчета «СписокСотрудников»

Рис. 2. Результат формирования отчета «СписокСотрудников»

 

ПРИМЕЧАНИЕ: отчет был создан в «1С: Предприятие» версии 8.3.