В начало

Список договоров с макетом

 

            Есть справочник «Договоры». Нужно сделать простенький отчет с макетом для вывода информации с кем какой договор заключен.

Рис. 1. Справочник «Договоры»

Рис. 1. Справочник «Договоры»

 

            По идее можно тупо вывести список справочника «Договоры» и с ним уже делать все что нужно, а можно поступить иначе и слегка заморочиться. Итак, переходим в конфигураторе в раздел «Отчеты» и создаем новый отчет «СписокДоговоров».

            Далее переходим в раздел «Макеты» свойств отчета и создаем новый макет. В макете создаем 2 области: Шапка и Строка. В шапке макета размещаем кратенько название, а в области «Строка» создаем 2 параметра для вывода данных из выборки, которую еще предстоит создать.

Рис. 2. Макет отчета «СписокДоговоров»

Рис. 2. Макет отчета «СписокДоговоров»

 

            Потом переходим в раздел «Формы» и создаем форму отчета. На форме создаем и размещаем атрибут «ТабДок». Атрибуту «ТабДок» устанавливаем тип «Табличный документ».

Рис. 3. Форма отчета «СписокДоговоров»

Рис. 3. Форма отчета «СписокДоговоров»

 

            Далее создаем действие при нажатии кнопки и автоматически нас переносит в модуль формы, где нужно заполнить 2 процедуры для формирования отчета.

 

Листинг 1. Процедуры в модуле формы

&НаКлиенте

Процедура СформироватьОтчет(Команда)

      СформироватьОтчетНаСервере(ТабДок);

КонецПроцедуры

 

&НаСервереБезКонтекста

Процедура СформироватьОтчетНаСервере(ТД)

      ТДчистить();

     

      Макет = Отчетыоговоры.ПолучитьМакет("Макет");

      Область_Ш = МакетолучитьОбласть("Шапка");

      Область_С = МакетолучитьОбласть("Строка");

     

      ТДывести(Область_Ш);

     

      Выборка = Справочникиоговоры.Выбрать();

      Пока Выборкаледующий() Цикл

            Область_С.Параметрыаименование = Выборка.Наименование;

            Область_С.Параметрыладелец = Выборка.Владелец;

            ТДывести(Область_С);

      КонецЦикла;

КонецПроцедуры

 

            После этого запускаемся в режиме «1Средприятие» и выбираем «Отчеты – Список договоров – Сформировать».

Рис. 4. Сформированный отчет «СписокДоговоров»

Рис. 4. Сформированный отчет «СписокДоговоров»