В начало

 «Остатки товаров» с запросом

            Есть регистр накопления «ОстаткиТоваров», нужно сформировать отчет.

            В данном отчете макет и запрос к регистру сведений сделаем сами.

Макет отчета «»ОстаткиТоваров» имеет 2 области: Шапка и СтрокаТаблицы. В шапке находится строка типа шаблон для ввода даты отчета. В области «СтрокаТаблицы» имеются 2 поля типа параметр: Номенклатура и Количество.

Рис. 1. Макет отчета «ОстаткиТоваров»

 

            На форме отчета расположены следующие реквизиты: «ДатаОтчета» с типом Дата и «ТабДок» типа Табличный документ. На закладке «Команды» свойств формы отчета создана команда «Сформировать».

Рис. 2. Форма отчета «ОстаткиТоваров»

 

            В модуле формы нужно написать пару процедур, одну с запросом НаСервереБезКонтекста, другую чтобы вызвать первую.

 

Листинг 1. Процедуры в модуле формы

&НаСервереБезКонтекста

Процедура СформироватьОтчет (ТабДок, ДатаОтчета)

      Макет = ОтчетыстаткиТоваров.ПолучитьМакет ("Макет");

      Область_Ш = МакетолучитьОбласть("Шапка");

      Область_С = МакетолучитьОбласть("СтрокаТаблицы");

     

      ТабДокчистить();

     

      Область_Ш.ПараметрыатаОтчета = ДатаОтчета;

            ТабДокывести(Область_Ш);

     

      Запрос = Новый Запрос;

      Запросекст = "ВЫБРАТЬ

                      | Номенклатура,

                      | КоличествоОстаток

                      |ИЗ

                      | РегистрНакоплениястаткиТоваров.Остатки(&ДатаОтчета, )";

      ЗапросстановитьПараметр("ДатаОтчета", ДатаОтчета);                  

      Результат = Запросыполнить();

      Выборка = Результатыбрать();

      Пока Выборкаледующий() Цикл

            Область_С.Параметрыоменклатура = Выборка.Номенклатура;

            Область_С.Параметрыоличество = Выборка.КоличествоОстаток;

            ТабДокывести(Область_С);

      КонецЦикла;

     

КонецПроцедуры

 

 

&НаКлиенте

Процедура Сформировать(Команда)

      СформироватьОтчет(ТабДок, ДатаОтчета);

КонецПроцедуры

 

            В результате должен получиться корявенький отчет как на рис. 3, который нужно еще дорабатывать и дорабатывать.

 

Рис. 3. Сам отчет