В начало

Карточки контрагентов

            Создание отчета «Карточки контрагентов» с использование КЗОР и макета. Данные для отчета берем из регистра сведений «Контакты».

Рис. 1. Макет отчета «КарточкиКонтрагентов»

Рис. 1. Макет отчета «Карточки контрагентов»

 

Листинг 1. Процедуры в модуле формы регистра сведений «Контакты»

&НаСервере

Функция ПечатьКарточекНаСервере()

                ТД = Новый ТабличныйДокумент;

                М = РегистрыСведенийонтакты.ПолучитьМакет("Карточки");

                ОблЗаголовок = М.ПолучитьОбласть("Заголовок");

                ОблШапка = М.ПолучитьОбласть("Шапка");

                ОблСтрока = М.ПолучитьОбласть("Строка");

                ТДывести(ОблЗаголовок);

               

                //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

                // Данный фрагмент построен конструктором.

                // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

               

                Запрос = Новый Запрос;

                Запросекст =

                               "ВЫБРАТЬ

                               |               Контактыонтрагент КАК Контрагент,

                               |               КонтактыидКонтактнойИнформации,

                               |               КонтактыначениеКонтактнойИнформации

                               |ИЗ

                               |               РегистрСведенийонтакты КАК Контакты

                               |ИТОГИ ПО

                               |               Контрагент";

               

                РезультатЗапроса = Запросыполнить();

               

                ВыборкаКонтрагент = РезультатЗапросаыбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

               

                Пока ВыборкаКонтрагентледующий() Цикл

                               // Вставить обработку выборки ВыборкаКонтрагент

                    ОблШапкаараметры.Контрагент=ВыборкаКонтрагент.Контрагент;

                               ТДывести(ОблШапка);

                              

                               ВыборкаДетальныеЗаписи = ВыборкаКонтрагентыбрать();

               

                               Пока ВыборкаДетальныеЗаписиледующий() Цикл

                               // Вставить обработку выборки ВыборкаДетальныеЗаписи

        ОблСтрокаараметры.ВидКонтактнойИнформации = ВыборкаДетальныеЗаписи.ВидКонтактнойИнформации;

                               ОблСтрокаараметры.ЗначениеКонтактнойИнформации = ВыборкаДетальныеЗаписи.ЗначениеКонтактнойИнформации;

                               ТДывести(ОблСтрока);

                               КонецЦикла;

                КонецЦикла;

                //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

               

Возврат ТД;

КонецФункции

 

&НаКлиенте

Процедура ПечатьКарточек(Команда)

                //Вывод табличного документа на экран

                Таб = ПечатьКарточекНаСервере();

                Табоказать();

КонецПроцедуры

 

Рис. 2. Отчет «КарточкиКонтрагентов»

Рис. 2. Отчет «Карточки контрагентов»