В начало

Номер ПП при безнале

 

            Имеется документ «ПриходДенег», необходимо выводить поле «Номер ПП» (Номер платежного поручения) только при выборе безналичного способа оплаты.

Рис. 1. Документ «ПриходДенег»

Рис. 1. Документ «ПриходДенег»

 

            Открываем/создаем форму документа, переходим к свойствам поля «СпособОплаты», выбираем на закладке свойств событие «ПриИзменении».

Рис. 2. Событие «ПриИзменении»

Рис. 2. Событие «ПриИзменении»

 

            Затем переходим в модуль и пишем код. При этом на сервере сравниваем значение объекта с перечислением, а на клиенте устанавливаем видимость поля.

&НаСервере

Функция ВидимостьСпособов(НаВходе)

      Если НаВходе = ПеречисленияпособыОплаты.Безналичные Тогда

            Результат = Истина

      Иначе

            Результат = Ложь

      КонецЕсли;

     

      Возврат Результат;

КонецФункции

     

 

&НаКлиенте

Процедура СпособОплатыПриИзменении(Элемент)

      ЭлементыомерПП.Видимость = ВидимостьСпособов(Объект.СпособОплаты);

КонецПроцедуры

           

            Теперь при выборе в поле «СпособОплаты» значения «Безналичные» поле «НомерПП» становится видимым, в остальных случаях оно будет скрыто.