В начало

Документ «Начисление зарплаты»

 

            Данный документ необходим для работы с регистром расчета, например «ОсновныеНачисления».

           Итак, переходим в дерево конфигурации в раздел «Документы», создаем новый объект, задаем ему имя. Переходим на закладку свойств объекта – «Подсистемы».

            На закладке «Подсистемы» ставим флаг принадлежности к выбранной подсистеме.

            На закладке «Данные» нужно создать табличную часть документа. Добавляем реквизиты табличной части.

Рис. 1. Закладка «Данные»

 

            Затем переходим на закладку «Движения». Здесь выбираем регистр расчета и нажимаем кнопку «Конструктор движений». Выбираем табличную часть, жмем кнопку «Заполнить выражения».

 

Рис. 2. Конструктор движения регистров

 

            Получаем некий авто-код. Редактируем его.

 

Процедура ОбработкаПроведения(Отказ, Режим)

       //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

      

       // регистр ОсновныеНачисления

       ДвижениясновныеНачисления.Записывать = Истина;

       Для Каждого ТекСтрокаНачисления Из Начисления Цикл

             Движение = ДвижениясновныеНачисления.Добавить();

             Движениеторно = Ложь;

             ДвижениеидРасчета = ТекСтрокаНачисления.ВидРасчета;

             ДвижениеериодРегистрации = Дата;

             Движениеотрудник = ТекСтрокаНачисления.Сотрудник;

             Движениеазмер = ТекСтрокаНачисления.Размер;

       КонецЦикла;

 

       //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

      

      

       Движенияаписать();

       Для каждого СтрокаНабора Из ДвижениясновныеНачисления Цикл

             Если НЕ СтрокаНабораидРасчета = ПланыВидовРасчета.Регламенты.Гонорар

                    Тогда Продолжить;

             КонецЕсли;  

       СтрокаНабораезультат = СтрокаНабора.Размер;        

    КонецЦикла;

       ДвижениясновныеНачисления.Записать();

      

      

КонецПроцедуры